Installed OpenOffice 3.0 on a Solaris 10 8/07 on SPARC

I have installed OpenOffice 3.0 ( which works fine on my OpenSolaris Laptop ) on
our SunRay-Installation on 2 T1000 servers. Install was fine, but starting OpenOffice lets the process hang:
[ewer@sunray1:/users/trinomic/ewer]>pstack 13677
13677: /opt/openoffice.org3/program/soffice.bin
----------------- lwp# 1 / thread# 1 --------------------
ff345898 lwp_park (0, 0, 0)
fcdc64d4 _XLockDisplay (31008, 31008, fcdc64cc, 2ccc8, 3c550, 31588) + 8
fe553af0 XGetExtensionVersion (31008, fe556e50, 3c550, fe554858, ff36e32c, ff3776f0) + 20
fe556224 _XiCheckExtInit (31008, 1, 3c550, 11e60, fcbe1b30, fe568000) + 8c
fe554858 XListInputDevices (31008, ffbfdfdc, f, ffbfdfe0, fcdc66c0, 0) + 2c
fcbe1b30 _gdk_input_common_init (3c848, 0, 11cc, 1d760, fcb95230, 1000) + 5c
fcbb8fc4 gdk_display_open (0, 3c848, fcc04234, 0, 1, fcbff244) + 2ec
fcb95230 gdk_display_open_default_libgtk_only (0, 6a0a4, fcc96bf0, 0, fcbff244, 3c) + 9c
f9a2a21c gtk_init_check (ffbfe1f4, ffbfe1e4, ff373580, ff272000, 1, 40000000) + 24
fcc96bf0 ???????? (26298, fee061c8, fccf4a5c, 7, 0, 160000)
fcc976c8 ???????? (21c88, 0, fc80bfb8, fcc96998, 26298, fccfb714)
fcc97cf0 create_SalInstance (21c60, fdcb45bc, fccfb6dc, fc816f4c, ffbfe2d8, ffbfe2dc) + 178
fdc09530 ???????? (ffbfe3d8, feda1420, fdca8f70, ffbfe368, 0, fe6f0008)
fdc0a744 ???????? (fdcd0264, 0, fdccf85c, fdc9730d, 1, 1800)
fd9a9ca8 __1cHInitVCL6FrknDcomDsunEstarDunoJReference4n0CElangUXMultiServiceFactory____C_ (ffbfe4d4, 0, fdca8f70, fdcb49fc, 1b68, 1800) + 114
fd9a9800 ???????? (0, ffbfe5a8, fdcb45a8, 0, fdca8f70, fdcb45bc)
fd9a9a00 __1cGSVMain6F_C_ (0, 24310, fdcb45a8, fdca8f70, 2380, fdcb45bc) + 20
fed58138 soffice_main (800, ffbfe5a8, 84c, 800, 848, 800) + c4
00010ab0 ???????? (1, ffbfe704, 0, 0, 0, 0)
00010a94 main (1, ffbfe704, ffbfe70c, 21000, ff2700c0, ff270100) + 10
00010a6c _start (0, 0, 0, 0, 0, 0) + 108
----------------- lwp# 2 / thread# 2 --------------------
ff345898 lwp_park (0, fef7be08, 0)
ff33f850 cond_wait_queue (ff1d8608, ff1d84a0, fef7be08, 0, 0, 0) + 28
ff33fcc8 cond_wait_common (ff1d8608, ff1d84a0, fef7be08, 0, 0, 0) + 298
ff33fe60 _cond_timedwait (ff1d8608, ff1d84a0, fef7bf30, ff06a490, ff3457f8, 0) + 34
ff33ff54 cond_timedwait (ff1d8608, ff1d84a0, fef7bf30, b280e0, 4905688b, 49056881) + 14
ff33ff94 pthread_cond_timedwait (ff1d8608, ff1d84a0, fef7bf30, ff06a490, ff3457f8, fef7bf38) + c
ff02d810 ???????? (a, 59407, ff06a490, b280e0, 4905688b, 49056881)
ff02d994 ???????? (a, 0, ff1d84b8, ff06a490, 5f4, ff1d84b8)
ff3457f8 _lwp_start (0, 0, 0, 0, 0, 0)
It does not matter if I use the German localization or the en-US version.