Feb 27, 2009

intel graphics on Build 108 is back again with manual workaround

I had problems with the intel driver in Build 107.

Today Niveditha Rau posted on the xwin-discuss list a response to my problem with a new intel driver for 32 and 64 bit systems.

On my new installed Build 108 system, I copied his intel-drivers and set my
xorg to use the intel driver.

Now on Build 108 the intel driver is back and I have an X-system using the
external monitor in combination with the laptop-LCD-Display by using xrandr.

Search for the title "
IPS upgrade to Build 107 -> X fails to start on intel Chipset"
on the xwin-discussion list at opensolaris.org. There are the drivers attached.

Upgrade OpenSolaris to Build 108

Today I upgraded my system to Build 108 of OpenSolaris with the IPS-Package system.

pkg refresh
pkg image-update


Everything went fine and I didn't have any problem. Build 108 works on my
FUJITSU SIEMENS LIFEBOOK S6120

Feb 25, 2009

Deploying application in SAP Netweaver -> nothing works anymore

Yesterday I deployed an application in SAP Netweaver in the textconsole, but the
deployment never returned.

So I stopped with Ctrl-C and the textconsole was also killed.
Attempting to restart the console showed that it couldn't connect anymore.
Also a restart of the whole machine didn't get the ports online again.

The LOG of the MaxDB was full.

So I created a backup-Device
with
zfs create -o mountpoint=/sapBackup pool/sapBackup

Connect to MaxDB:
/sapdb/programs/bin/dbmcli -d HDB -u SUPERDBA,Password
Create devices to use for backup:
medium_put LOG_BACKUP /sapBackup/LOG_BACKUP LOG
medium_put DATA_BACKUP /sapBackup/DATA_BACKUP DATA

info status
showed, that the LOG was to 100% full.

db_connect
established a connection to the database.

backup_start DATA_BACKUP DATA
backup_start LOG_BACKUP LOG
started the backup of the database.

After this the LOG was filled with 0% and SAP could be started again.
After some time a login with the textconsole was possible again.

Flash-Player 10 for Solaris is available

Adobe has now the flash-player 10 as a plugin for firefox available.
You can download from http://get.adobe.com/flashplayer/.

Copy the shared object into ~/.mozilla/plugins or in the installation directory
of firefox/plugins

Open about:plugins in the browser to see, if the plugin is used.

Feb 23, 2009

OpenSolaris Bible arrived today

Today the OpenSolaris Bible arrived.

I was deeply impressed about the index. There is really everything.
From Solaris history to installation, mangagement, security, development, virtualization, clustering, ...
on nearly 1000 pages.

Feb 21, 2009

Opensolaris upgrade to 107 failed part II

As I described in the first upgrade to Build 107, the intel graphics
driver does not work for me.
Today I managed the reconfigure xorg.conf to use the VESA driver.

My problem on the first attempt was, that I configured 2 Cards on for the
LCD display and one for the external monitor. During the test
I configured card0 for vesa, but forgot card1. Card1 seems to be the one
necessary for the LCD display.

So Build 107 is up and running, but with VESA instead of the native intel
graphics driver.

But as I saw today, the multihead does not work with vesa

For me as a native German speaker, I'm also using a german environment and
much more is the german keyboard.

There is also a problem in Build 107 with recognizing the correct keyboard.

See http://blogs.sun.com/alanc/entry/xorg_1_5_3_in for a workaround.

You have to set the Keyboard rules in the xorg.conf.

Section "InputDevice"
Identifier "Keyboard0"
Driver "kbd"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "gb"
EndSection

Feb 20, 2009

Feb 19, 2009

OpenSolaris Upgrade to 107 failed

Today I upgraded to Build 107 of OpenSolaris. Everything was fine, but on the
reboot, the GUI didn't start.

There is a problem in the Xorg-Server regarding the intel chipset.

The logfile says:

Couldn't find PLL settings for mode!


Also removing my xorg.conf didn't help.

Perhaps I have to play around using VESA-Drivers until there is a fix.

Rebooting to Build 106 worked without problems.

Feb 18, 2009

VirtualBox 2.1.4 on OpenSolaris Build 106 and OpenSusE11.1

VirtualBox 2.1.4 is installed on the OpenSolaris Build 106 installation.
In the virtual environment OpenSuSE 11.1 was installed via DVD.

Network was configured to be NAT.

After downloading Skype sound was available from the VirtualBox, but the
microphone was not useable.

Worked not bad, but with 2G RAM and an 1.6 GHz Pentium it needs some more memory.

Feb 17, 2009

very slow Solaris 10 system with some zones

I've a Sun Fire V240 with Solaris 10 8/07 and 7 zones. The system worked
smooth during the last time.
Last week I was on vacation. On returning a colleague claimed about a slow
server ( a zone on the system ).
The investigation with prstat, mpstat, vmstat on the global zone didn't reveal
any much work.

CPU's were about 90% idle, no paging....

But listening directories and so on where very slow. Also some ssh logins
timed out.

Logging in via the LOM on the console, showed from time to time some processes in the zones, which can't grow their stack because of missing
swap space.

After looking into /zones/*/root/tmp, I've found that there were a lot of files in
tmp.

After cleaning up each zones /tmp the system came back to the usual performance and the colleague was happy again.

This is a fact many people miss when using solaris, that /tmp is located in the
virtual memory.

So do not store large files in /tmp. They are lost in case of a reboot.

Feb 4, 2009

Upgarde OpenSolaris Laptop to Dev-Build 106

Upgrade was done with about 550 MB download.


After restarting, printers:snmp with the automatic printer discovery, failed to
start in Build 106.
The log file revealed :
[ Feb 4 13:09:28 Executing start method ("/lib/svc/method/svc-network-discovery start snmp"). ]
/usr/bin/dbus-send --system --print-reply --dest=org.freedesktop.Hal --type=method_call /org/freedesktop/Hal/devices/network_attached org.freedesktop.Hal.Device.NetworkDiscovery.EnablePrinterScanningViaSNMP int32:60 string:public string:0.0.0.0
Error org.freedesktop.DBus.Error.AccessDenied: A security policy in place prevents this sender from sending this message to this recipient, see message bus configuration file (rejected message had interface "org.freedesktop.Hal.Device.NetworkDiscovery" member "EnablePrinterScanningViaSNMP" error name "(unset)" destination "org.freedesktop.Hal")
[ Feb 4 13:09:28 Method "start" exited with status 1. ]
Comparing the configuration for dbus in

/etc/dbus-1/system.conf
After comparing the file from Build 105 with 106, there where some
changes.
So I copied the system.conf from Build105 to Build 106 and restarted
svc:/system/dbus:default

After this a clear of
svc:/network/device-discovery/printers:snmp

brought also the printer-discovery online
Hope it will work, because currently the printers in the network are online.

  • Firefox 3.1b2 is installed.
  • Login as a different user is working again

Feb 2, 2009

static code analysis is described in the German iX

Today I red the german iX magazin. The main story for the february 2009 issue is static
code analyses.

For java there are described PMD, FindBugs and Hammurapi.

For PMD and FindBugs there is also a plugin for eclipse and for netbeans.
The update-site for netbeans is https://sqe.dev.java.net/updatecenters/sqe/updates.xml.