Upgraded to OpenSolaris Build 131 from Build 129

Since the upgrade to 130 failed ( X didn't start ), I attempted to
upgrade to Dev-Build 131.

The first run had an error:
root@solewer:~# pkg image-update --be-name OSOL_131                           
DOWNLOAD                                  PKGS       FILES    XFER (MB)
Completed                              1209/1209 38342/38342  725.5/725.5

PHASE                                        ACTIONS
Removal Phase                            12092/19720
Warning - directory usr/share/gdm/applications not empty - contents preserved in /tmp/tmpuYkNOI/var/pkg/lost+found/usr/share/gdm/applications-20100122T221741Z
Removal Phase                            12358/19720
Warning - directory usr/X11/share/man not empty - contents preserved in /tmp/tmpuYkNOI/var/pkg/lost+found/usr/X11/share/man-20100122T221742Z
Removal Phase                            12604/19720
Warning - directory usr/X11/lib/X11/fonts/TrueType/unifont not empty - contents preserved in /tmp/tmpuYkNOI/var/pkg/lost+found/usr/X11/lib/X11/fonts/TrueType/unifont-20100122T221742Z

Warning - directory usr/X11/lib/X11/fonts/TrueType/mgopen not empty - contents preserved in /tmp/tmpuYkNOI/var/pkg/lost+found/usr/X11/lib/X11/fonts/TrueType/mgopen-20100122T221742Z

Warning - directory usr/X11/lib/X11/fonts/TrueType/kacst not empty - contents preserved in /tmp/tmpuYkNOI/var/pkg/lost+found/usr/X11/lib/X11/fonts/TrueType/kacst-20100122T221742Z

Warning - directory usr/X11/lib/X11/fonts/TrueType/ipafont not empty - contents preserved in /tmp/tmpuYkNOI/var/pkg/lost+found/usr/X11/lib/X11/fonts/TrueType/ipafont-20100122T221742Z

Warning - directory usr/X11/lib/X11/fonts/TrueType/indic-fonts-core not empty - contents preserved in /tmp/tmpuYkNOI/var/pkg/lost+found/usr/X11/lib/X11/fonts/TrueType/indic-fonts-core-20100122T221742Z

Warning - directory usr/X11/lib/X11/fonts/TrueType/hanyang not empty - contents preserved in /tmp/tmpuYkNOI/var/pkg/lost+found/usr/X11/lib/X11/fonts/TrueType/hanyang-20100122T221742Z

Warning - directory usr/X11/lib/X11/fonts/TrueType/gentium not empty - contents preserved in /tmp/tmpuYkNOI/var/pkg/lost+found/usr/X11/lib/X11/fonts/TrueType/gentium-20100122T221742Z


Warning - directory usr/X11/lib/X11/fonts/TrueType/arphic not empty - contents preserved in /tmp/tmpuYkNOI/var/pkg/lost+found/usr/X11/lib/X11/fonts/TrueType/arphic-20100122T221742Z

Warning - directory usr/X11/lib/X11/fonts/TrueType/arabeyes not empty - contents preserved in /tmp/tmpuYkNOI/var/pkg/lost+found/usr/X11/lib/X11/fonts/TrueType/arabeyes-20100122T221742Z
Removal Phase                            19720/19720
Install Phase                            29964/35928Action install failed for 'usr/X11/lib/X11/fonts/TrueType' (pkg://opensolaris.org/SUNWxorg-compatlinks):
  ActionExecutionError: attempted to remove link 'usr/X11/lib/X11/fonts/TrueType' but found a directory
 The running system has not been modified. Modifications were only made to a clone of the running system.  This clone is mounted at /tmp/tmpuYkNOI should you wish to inspect it.
pkg: An unexpected error happened during image-update: attempted to remove link 'usr/X11/lib/X11/fonts/TrueType' but found a directory
Traceback (most recent call last):
  File "/usr/bin/pkg", line 3139, in handle_errors
    __ret = func(*args, **kwargs)
  File "/usr/bin/pkg", line 3116, in main_func
    return func(img, pargs)
  File "/usr/bin/pkg", line 947, in image_update
    ret_code = __api_execute_plan(op, api_inst)
  File "/usr/bin/pkg", line 615, in __api_execute_plan
    api_inst.execute_plan()
  File "/usr/lib/python2.6/vendor-packages/pkg/client/api.py", line 587, in execute_plan
    self.__img.imageplan.execute()
  File "/usr/lib/python2.6/vendor-packages/pkg/client/imageplan.py", line 860, in execute
    p.execute_install(src, dest)
  File "/usr/lib/python2.6/vendor-packages/pkg/client/pkgplan.py", line 240, in execute_install
    dest.install(self, src)
  File "/usr/lib/python2.6/vendor-packages/pkg/actions/link.py", line 85, in install
    ignoreerrno=True)



ActionExecutionError: attempted to remove link 'usr/X11/lib/X11/fonts/TrueType' but found a directory
 
 
pkg: This is an internal error.  Please let the developers know about this
problem by filing a bug at http://defect.opensolaris.org and including the
above traceback and this message.  The version of pkg(5) is '512c6b2dfda2'
.

A reboot to the new installed system caused a kernel panic about missing
module misc/pcie.

The problem with the directory is documented in Bug 13912 .

I removed the directory and did the update again:


root@solewer:/# pkg image-update --be-name OSOL_131                           
DOWNLOAD                                  PKGS       FILES    XFER (MB)
Completed                              1209/1209 38342/38342  725.5/725.5
 
PHASE                                        ACTIONS
Removal Phase                            12076/19720
Warning - directory usr/share/gdm/applications not empty - contents preserved in /tmp/tmp_S1uel/var/pkg/lost+found/usr/share/gdm/applications-20100123T072744Z
Removal Phase                            12364/19720
Warning - directory usr/X11/share/man not empty - contents preserved in /tmp/tmp_S1uel/var/pkg/lost+found/usr/X11/share/man-20100123T072746Z
Removal Phase                            19720/19720
Install Phase                            35928/35928
Update Phase                             35280/35280
PHASE                                          ITEMS
Reading Existing Index                           8/8
Indexing Packages                          1209/1209
Optimizing Index...
PHASE                                          ITEMS
Indexing Packages                          1394/1394
pkg: unable to unmount /tmp/tmp_S1uel
Deleting content cache
 
---------------------------------------------------------------------------
NOTE: Please review release notes posted at:
 
http://opensolaris.org/os/project/indiana/resources/relnotes/200906/x86/
---------------------------------------------------------------------------



This run seems to be better.

A reboot showed a hanging X-Server.


In the console the following error is printed:

Jan 23 12:13:07 solewer ip: [ID 224711 kern.warning] WARNING: Memory pressure: TCP defensive mode on
Jan 23 12:13:07 solewer gdm-binary[1555]: [ID 702911 daemon.warning] WARNING: Unable lookup numeric info: non-recoverable name resolution failure

The GDM problem is discussed in this message thread. 
After changing and rebooting X still hangs.

Xorg.0.log shows:

X.Org X Server 1.7.3
Release Date: 2009-12-3
X Protocol Version 11, Revision 0
Build Operating System: SunOS 5.11 i86pc
Current Operating System: SunOS solewer 5.11 snv_131 i86pc
Build Date: 04 January 2010  02:18:14PM
Solaris ABI: 32-bit
Current version of pixman: 0.16.4
    Before reporting problems, check http://sunsolve.sun.com/
    to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
    (++) from command line, (!!) notice, (II) informational,
    (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Sat Jan 23 13:56:56 2010
(II) Loader magic: 8217908
(II) Module ABI versions:
    X.Org ANSI C Emulation: 0.4
    X.Org Video Driver: 6.0
    X.Org XInput driver : 7.0
    X.Org Server Extension : 2.0
(--) using VT number 3

(--) PCI:*(0:0:2:0) 8086:3582:10cf:120e Intel Corporation 82852/855GM Integrated Graphics Device rev 2, Mem @ 0xd8000000/134217728, 0xd0000000/524288, I/O @ 0x00001800/8, BIOS @ 0x????????/65536
(--) PCI: (0:0:2:1) 8086:3582:10cf:120e Intel Corporation 82852/855GM Integrated Graphics Device rev 2, Mem @ 0xe0000000/134217728, 0xd0080000/524288, BIOS @ 0x????????/65536
(--) console driver: SUNWtext
(==) Using default built-in configuration (30 lines)
(==) --- Start of built-in configuration ---
......

(==) No monitor specified for screen "Builtin Default fbdev Screen 0".                                                      
    Using a default monitor configuration.                        
(==) Disabling SIGIO handlers for input devices       
(==) Automatically adding devices                     
(==) Automatically enabling devices                   
(==) FontPath set to:                                 
    catalogue:/etc/X11/fontpath.d                     
(==) ModulePath set to "/usr/lib/xorg/modules,/usr/X11/lib/modules/"
(II) Cannot locate a core pointer device.             
(II) Cannot locate a core keyboard device.            
(II) The server relies on HAL to provide the list of input devices.
    If no devices become available, reconfigure HAL or disable AutoAddDevices.
(II) LoadModule: "extmod"                             
(II) Loading /usr/lib/xorg/modules/extensions/libextmod.so
(II) Module extmod: vendor="X.Org Foundation"         
    compiled for 1.7.3, module version = 1.0.0        
    Module class: X.Org Server Extension              
    ABI class: X.Org Server Extension, version 2.0    
(II) Loading extension MIT-SCREEN-SAVER               
(II) Loading extension XFree86-VidModeExtension       
(II) Loading extension XFree86-DGA                    
(II) Loading extension DPMS                           
(II) Loading extension XVideo                         
(II) Loading extension XVideo-MotionCompensation      
(II) Loading extension X-Resource                     
(II) LoadModule: "dbe"                                
(II) Loading /usr/lib/xorg/modules/extensions/libdbe.so
(II) Module dbe: vendor="X.Org Foundation"            
    compiled for 1.7.3, module version = 1.0.0        
    Module class: X.Org Server Extension              
    ABI class: X.Org Server Extension, version 2.0    
(II) Loading extension DOUBLE-BUFFER                  
(II) LoadModule: "glx"                                
(II) Loading /usr/lib/xorg/modules/extensions/libglx.so
(II) Module glx: vendor="X.Org Foundation"            
    compiled for 1.7.3, module version = 1.0.0        
    ABI class: X.Org Server Extension, version 2.0    
(==) AIGLX enabled                                    
(II) Loading extension GLX                            
(II) LoadModule: "dri"                                
(II) Loading /usr/lib/xorg/modules/extensions/libdri.so
(II) Module dri: vendor="X.Org Foundation"      
    compiled for 1.7.3, module version = 1.0.0  
    ABI class: X.Org Server Extension, version 2.0
(II) Loading extension XFree86-DRI              
(II) LoadModule: "dri2"  
(II) Loading /usr/lib/xorg/modules/extensions/libdri2.so
(II) Module dri2: vendor="X.Org Foundation"     
    compiled for 1.7.3, module version = 1.1.0  
    ABI class: X.Org Server Extension, version 2.0
(II) Loading extension DRI2
(II) LoadModule: "ia"         
(II) Loading /usr/lib/xorg/modules/extensions/libia.so
(II) Module IANAME: vendor="X.Org Foundation"   
    compiled for 1.7.3, module version = 1.0.0  
    ABI class: X.Org Server Extension, version 2.0
(II) Loading extension SolarisIA
(II) LoadModule: "xtsol"        



So I keep still at Build 129.